.ydrologic Engineering,Center's (CEIWR-HEC) River’Analysis System (HEC-RAS)

The Hydrologic Engineering Center (HEC), an organization within the Institute for Water Resources, is the
designated Center of Expertise for the U.S. Army Corps of Engineers in the technical areas of surface and
groundwater hydrology, river hydraulics and sediment transport, hydrologic statistics and risk analysis,
reservoir system analysis, planning analysis, real-time water control management and a number of other
closely associated technical subjects. HEC supports Corps field offices, headquarters, and laboratories by
providing technical methods and guidance, water resources models and associated utilities, training and
workshops, accomplishing research and development, and performing technical assistance and special
projects. The products that are developed from these activities are for the Corps but are

available to the public and may be freely downloaded from this web site.

http://www.hec.usace.army.mil/software/hec-ras/ i |

This tutorial is a primer for hydrological modeling using HEC- RAS. This software is exceptionally in-depth
and covers many variables and types of modeling algorithms to adequately predict affected areas of a river
system. This primer will cover the basics of Dynamic Flood Simulation (Unsteady Flow Modeling only) and
assumes a mid-level understanding of GIS (Geographic Information System) files, file types and spatial
modeling. By the end of this tutorial you will understand the basics of adding various volumes of simulated
water over time to a DEM (assumes a river) to see what parts of said DEM are flooded, flow volume and
visualize particle flow.

Setup

Download and install the HEC-RAS specific to your operating system. This software can be freely
downloaded by anyone. While, the Hydrologic Engineering Center (HEC) has many different hydro analysis,
simulation and GIS collaborative software we will only be looking at HEC-RAS.

In this guide, we are going to learn how to implement a few basic features of HEC-RAS, specifically creating
a dynamic flood simulation using unsteady flow modeling only. This animated model will show depth,
velocity, water surface elevation, particle tracing, and static velocity arrows on a terrain created from DEM.
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Our start files are a DEM (tif with .tfw) of a river segment and a projection (.prj) file of the same river
segment in the same units of measurement.

File Preparation

The files that are required to run a dynamic flood simulation are a “stream burned” DEM and an associated
projection file. We won’t be covering reaches, reach connectivity, river center lines, cut lines, banks, weirs,
sediments, ice cover, etc. and their associated files.

1. A “stream burned” DEM is created as part of the process
for Watershed and Stream Network Delineation. It is
literally a set of bridge burning algorithms. Having this
type of DEM is very important because the data
collecting sensors that create the cloud point data that
the DEM is based on just ‘see’ the tops of bridges and
represent them as changes in elevation. This would block
the simulated flow of water and create pools where there
are none. Luckily “stream burned” DEM’s are quite
prevalent but first check to make sure your stream isn’t
blocked, if it is, there are various tools that can
accomplish the required stream delineation within most
GIS software.

2. The DEM being used should be of as high a resolution as
possible.

3. The projection file must be of the same projection as the
DEM as it sets all the measurements for the model.
Unfortunately, HEC-RAS’s project files have the same file
extension as ESRI projection files (.prj). This is where
good file management is key.

Getting Started
1. Open HEC-RAS

St HEC-RAS 5.0.7
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2. Select File > New project... on the start dialog box. Give it a title. (Be aware that the file
extension is the same as a .prj projection file for a shapefile, you will have both in the project.)
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5. Right click on Terrain > Create a New RAS Terrain.
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6. Click Yes to set the HEC-RAS Reference System

HEC-RAS Spatial Reference System

@B 't is recommended that the Project Spatial Reference System
(SRS) be set before creating GIS data. Would you like to set
the SRS now?

Click Yes' to jump to the dialog where the ESRI Projection file
(*.prj) file is set, or 'no’ to go directly to the terrain creation
dialag.
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7. Select the projection (.prj) specific for the river study area (.tif)
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8. Click + and select the river study area (.tif). Next be sure the Terrain file and folder are being
created in a known location. Click Create — it may take some time.

—Input Terrain Files
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Filename
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Filename: |C WHEC_RAS\DynFlood\Temain\Temain hdf ﬁl

9. Result
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Calibrating/Creating the Model
10. Exit RAS Mapper and select Edit > Geometric Data on the main HEC-RAS window.
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11. In the Geometric Data window is the newly created Terrain. Select the 2D Flow Area and define
the modeling area by drawing a polygon around the river within the Terrain (Ideally on the highest
elevations). Double Click to finish the drawing and enter a name for the 2D Flow Area.

Geometric Data
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12. Remove the fill in the 2D Flow Area Edit>Lines and Symbols...
Select the box Under the Line/Fill column of Schem 2D Row
Click the outline box (top one) under the Fill Pattern column




13. Select the BC lines option. Boundary Conditions are essentially telling the model what the start
and end conditions are for the section of the river DEM being studied. Draw the first Boundary
Condition (as a line) upstream on the DEM outside the 2D Flow Area and the second downstream
(it will snap to the 2D Flow Area). Draw the BC bank to bank on top of water. Dbl Click to finish
drawing. Name them both appropriately.
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14. Click on the 2D Flow Area (Magenta circle) > Edit 2D Flow Area.
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15. Click on the Generate Computation Points on Regular Interval with All Breaklines. Enter 50 in the
Spacing DX and Spacing DY then Click>Generate points in 2D flow area. This is the size of the
square mesh cells that will be created. The 2D Flow Areas dialog box will be updated with the

number cells that will be created. Finally, Click>Force Mesh Recomputation.
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16. Click>0K
File > Save geometry Data As — Save in your main folder.




17. In the main HEC-RAS window, go to Edit > Unsteady Flow Data
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18. This is where the Boundary Conditions are set. Boundary Conditions must be set as part of the
model calibration. First click the Boundary Condition box beside DownstreamBC. Above, different
Boundary Condition Types become available.

Brief Description:
Stage Hydrograph - flow gage data on the stream, or tidal cycle
Flow Hydrograph - gage data converted to flow
Stage & Flow - combined observed stage and forecasted flow
Rating Curve - rating at a gauged location, or steady-flow rating
Normal Depth - average slope of stream to estimate energy slope

Since this is only a primer we are going to keep this simulation as straight forward as possible.
For the DownstreamBC select Normal Depth. Set the Friction Slope to .012 it is derived from
Slope Calculation: Rise/Run

(highest raster elevation) 252.71m — (lowest raster elevation) 211.71m = 41m

(rough length of river) 3400m

Slope: 41m/3400m =.012

I B8 Unsteady Flow Data - Test2 - O x
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| Boundary Conditions | titial Conditions |
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OK Cancel

19. Second click the Boundary Condition box beside UpstreamBC and select Flow Hydrograph This
will be setting the volume (m3/s) of “water” flowing into the model from up stream.




Select Fixed Start Time: Pick a date and time (24h) further than 5 days in the past as the
Hydrograph Data chart is automatically filled in hourly (Data time interval: 1 Hour) 5 days forward
of your chosen date.
In the Hydrograph Data chart start filling in the Flow (cfs) with real numbers or fun numbers.
Row 1 —20is a good start to “fill” the river model
Row 24(?) — 20 to give the model time to “fill”
Row 31(?) — 150 start flooding...
Row 87(?) —150
Row 91(?) — 50 ramp down the volume in the model

Row 100 - 50
Click Interpolate Missing Values. It will fill in the values in-between and ramp them to the different
volume.
Be sure to set the EG Slope for distributing flow along BC Line: 0.012 the same as our calculated
slope.

Flow Hydregraph

SA: 2Dflo BCLine: UpStreamBC

" Read from D55 before simulation

File:
Path:

% Enter Table Data time interval: |1 Hour ..I.]

 Select/Enter the Data's Starting Time Reference -

" Use Simulation : Date: 102APR2019 Time: 123:00
* Fixed Start Time: Date: 02APR2019 _-]'ﬁme: 230
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Hydrograph Data —
Date Simulation Time | Flow
(hours) | (cfs)
79 06Apr2019 0500 75:00 / |150
80 06Apr2019 0600 75:00 / |10
81 06Apr2019 0700 80:00 150
82 06Apr2019 0800 31:00 150
83 06Apr2019 0500 82:00 150
84 06Apr2019 1000 83:00 150
85 06Apr2019 1100 3400 150
86 06Apr2019 1200 85:00 150
87 06Apr2019 1300 86:00 150
88 06Apr2019 1400 87:00 1325
89 06Apr2019 1500 88:00 100
90 06Apr2019 1600 89:00 75
91 06Apr2019 1700 90:00 50
92 06Apr2019 1300 91:00 50
a3 06Apr2019 1500 92:00 50
o4 06Apr2019 2000 93:00 50
95 06Apr2019 2100 S4:00 50
96 06Apr2019 2200 95:00 50
97 06Apr2019 2300 96:00 |50
98 06Apr2019 2400 97:00 _ |50
99 07Apr2019 0100 98:00 _ |50
100 07Apr2019 0200 95:00 50

\____________/
~Time Step Adjustment Options ("Critical” boundary conditions) — ]
[~ Monitor this hydrograph for adjustments to computational time step
Max Change in Flow {(without changing time step):
Min Flow: Multiplier: EG Slope for distributing flow along BC Line:  g,g lzm

—PWDEE | ok |  Cancel |

20. To see the flow curve Click Plot Data
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21. Save the unsteady Flow created:

Unsteady Flow Data dialog -
22. Back on the HEC-RAS main

shown in the image below.

File > Save Unsteady Flow Data
dialog Select Run > Unsteady Flow Analysis. Select the options as
Give the analysis a Short ID. Ensure the Start Date and End Date

correspond with your Flow Hygrograph date time. To start Click Compute.
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23. Success:
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Simulation: |
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(Map:

—Computation Messages

IPlan: "Plan 01' (DFS1.p01)
Simulation started at: 070ct2025 02:01:13 PM

Writing Plan GIS Data...

Completed Writing Plan GIS Data

\Writing Geometry...

Geometry 'Geometry' assodation was set to the first valid terrain layer (Terrain)
Computing 20 Flow Area 'FlowArea' tables: Property tables do not exist.

2D Flow Area Flowares' tables complete 5.09 sec

Completed Writing Geometry

Writing Event Conditions ...

Completed Writing Event Condition Data

‘Geometric Preprocessor HEC-RAS 6.6 September 2024

Finished Processing Geometry

Performing Unsteady Flow Simulation HEC-RAS 6.6 September 2024

Unsteady Input Summary:
2D Unsteady Diffusion Wave Equation Set (fastest)
2D number of Solver Cores: 24

Overall Volume Accounting Error in Acre Feet: 0.01919
Overall Volume Accounting Error as percentage: 0.002371
Flease review "Computational Log File™ output for volume accounting details

Pause | Make Snapshot of Resulks

Running the Simulation
24. To visualize the results of the computations open the RAS Mapper window the main dialogue box.
Under Results> Check ‘Your Plan’
The simulations that can be run are Depth, Velocity and WSE (Water
Surface Elevation)
Just Press Play B>
The time can be adjusted with the slider.
With any of the simulations checked on can show the Static Velocity

Arrows - and Particle Tracing N
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Simulation running with Particle Tracing.
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Wrapping Up

As mentioned in the introduction HEC RAS is computational hydrology software that can account for many
variables. This tutorial has only covered one small part of HEC RAS. With your simulation up and running
try changing some of the variables to see their effects. Start slow, and look into websites like ‘HEC-RAS
Help’, NOAA’s National Weather Service ‘Hydrologic Science and Modeling Branch (HSMB)/,
‘researchgate.net’ etc.

Trouble Shooting Hints

Check your 2D Flow Area mesh for errors — The software will highlight problem areas after generation,
right click to edit the mesh.

Force Mesh Re-computation again. This wills solve some 2D Flow Area mesh errors.
Try making the 2D Flow Area mesh cells larger so there are less to render
Make sure the BC’s are drawn outside the 2D Flow Area as the default is ‘External’

Double check that your Friction Slope (Normal Depth Downstream Boundary) and EG Slope for
distributing flow along BC Line (Bottom of Flow Hydrograph chart) — for this example they are the same
number.

UNIVERSITY OF WATERLOO GEOSPATIAL CENTER
https://uwaterloo.ca/library/geospatial/




	Setup
	File Preparation
	Getting Started
	Calibrating/Creating the Model
	Running the Simulation
	Wrapping Up
	Trouble Shooting Hints
	UNIVERSITY OF WATERLOO    GEOSPATIAL CENTER  https://uwaterloo.ca/library/geospatial/


