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Introducing GIS Cloud 

 
What is GIS Cloud? 

 
GIS Cloud is the first purely web based GIS powered by cloud computing that provides full desktop GIS features 

enriched by the web. GIS Cloud offers easy and efficient visualization, analysis and exploration of geographic 

information. The primary goals of the GIS Cloud platform is to simplify exchange of geographical information 

between users and offer an easy way to analyze this information regardless of the location of its users. By using GIS 

Cloud our users access the full power of desktop GIS, allowing for such activities as geospatial analysis, spatial 

intelligence, the creation of customized mapping reports and publishing geographic analysis on the Web. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Create an Account 
 

Go to giscloud.com and click on “Free Signup”, it will direct you to the page where you can create a new account. 
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Main User Interface 
 

When you begin to use GIS Cloud you must first get acquainted with the user interface. It is a part 

of platform which offers complete oversight of projects, as well as functionality for working with the 

geospatial data itself. 
 

In this manual, we have placed a red number over each pictured interface; that number corresponds 

to the instructions for each product feature. 

 
1. Login and My Account – You need to log in using your User Name and Password to 

access Map Editor. After that you will be able to use the application fully. After logging 

in, you will be able to modify your user account. 

 

2. Tool Ribbon – Here we offer complete access to the application's features: creating 

projects and maps, adding layers as well as conducting your analysis and performing 

data management. The tabs above the ribbon reveal additional tools. Tool Ribbon 

functions are described in the separate chapter Tool Ribbon. 

 
3. Toolbar – Provides the tools needed for basic operations with maps. Toolbar functions are 

described in the separate chapter Toolbar. 

 
4. Project Name bar - Displays the project name as a link. You can send someone a link to 

the map by using the address that the link points to, or you can refresh the map by clicking 

on the link. 

 
5. Layer panel –A "table of contents" type of display for the active project.The layer 

http://www.giscloud.com/manual/map-editor-manual/getting-started/main-user-interface/tools-ribbon-overview/
http://www.giscloud.com/manual/map-editor-manual/getting-started/main-user-interface/toolbar/
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panel offers the following functionality: 

 
6. Map Viewer – Map display of visible layers and cartographic features. 

 
7. Layer Data Table – Table displaying all attribute records and fields of a selected dataset. 

 
8. Info Table and Search tool - View info about selected feature and search for specific 

features. 

 

9. GIS Cloud Team Help – start a conversation with a GIS Cloud Member for help 

 

For better viewing 

experience we've 

implemented an option to 

hide tool ribbon and layer 

panel. The red dots (on 

picture below) mark 

positions of the sliders 

where you can toggle the 

ribbon, the layer panel and 

the info panel (hidden by 

default) on and off. 

 

 

 

 

Home Tab 

 

The Home tab is a 

centralized place to 

access all maps you have 

access to - your own 

maps, maps someone has 

shared with you, or 

public maps. The menu 

on the left (1) provides 

not only easy access to 

all of your maps, but easy 

discovery of and access 

to new maps and data. 

You can browse available 

maps by directories, 

search for maps or just go 

for the recently open 

maps. The gallery (2) 

provides easy access to 

all of the maps available to your user account, whether the maps are created by you, shared with you or 

pub 

 

Tool Bar 
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The tool bar functions are:  

 

 Show/Hide Toolbar – shows or hides the toolbar    

 

 Measure Tool -  measures the distance from one point to another  

 

 View Entire Map – Zooms out showing the entire map 
 

 Show google street view – Shows the street view of an selected point  

 

 Zoom to current location -  Locates your current location  

 

 Freehand Selection – Enables the user to draw freely. The drawn area is than selected  

 

 Zoom out – when clicked, it zooms out from the center  

 

 Zoom in – When clicked, it zooms in from the center  

 

Pan – enables the user to interactively move the Map View position  

 

 Identify - Identifies an element on the map and shows its attribute information. 

 Area Selection - Clicking and dragging a rectangular box with the mouse creates a selected 

set of a features from an active layer.  More about the Select tool in the chapter "Selecting Layers 

and Objects". 

 

  Measuring Tool - Interactive display of distances on the Map View. Left clicking will allow 

distance display over multiple vertices. 

 

  Print - Any created map can be printed. 

 Scale 

 

 Jump to Coordinates - Zoom to a set of coordinates – The current 

coordinates of the mouse cursor are displayed. To define specific coordinates and have the view zoom 

to the specified position, left click; enter coordinate information. 

 

  Number of Selected Objects on the Map 

 
Tools Ribbon Overview 

 
The Tool Ribbon provides you with clear view of all tools within their categories. Easy access to 

tools through the ribbon allows you to use GIS Cloud more efficiently. The following is a brief 
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overview of the tools on the ribbon; a more detailed description of the tools will follow. 

 

Layers Panel  

The Layers panel shows all of the layers of a selected project. The Layer panel also functions as 

a legend. The following cartographic options are available:  

 

Eye tool – used to hide or show a layer  

 

 

Slider – sets the transparency of the layer  

 

 

Adjust layer – drag layer in desired order  

 

 

Lock layer – layers can’t be edited when activated  

 

Folder layer -  hides the content within the folder in the 

panel but not on the map  

 

*other features to change layer features are found in the 

layer panel toolbar  

 

 

 

 

Info Panel and Data Grid 
 

On the Map Editor's main interface, you can access the table overview of the selected feature's 

attribute data. This information is available in two ways:  

 

1. Info Panel – Use the 

info tool to select a 

feature and attribute 

data is shown in the 

info panel  

2. Data Grid – You can 

see all the data within 

a layer with the grid. 

Select the layer and 

open the data grid; this 

is an easy to access the 

data and an 

understanding of 

which data in table is 

visualized as objects 
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on the map. Select a row in the table and it will be shown on the map. 

 

Search Tools  
 
Search tools enable you to search for attribute data in the tables or search Google Maps addresses and 
locations. You can 
find Search option in 
the toolbar. 
 

There are two ways to 

search data: 

1. You can search 

attribute data 

from the layers by 

clicking on the 

GIS Cloud button 

or 

2. you can search 

Google maps by 

clicking on the 

Google maps 

button. 

 

Creating a New Map  
 

A map is created in the following way:  

 

1. Select the Map tab.  

2. Select New Map.  

 

A map can be created from the Home tab as well by selecting 

Create New Map in the upper left corner.  

 

The next steps are to provide a map name and select a base 

map.  

 

Additional information about the map can be edited under 

the Map Tab in Map Properties.  

You can set the following parameters:  

 Map name 

 Map Description 

 Map Copyright – Allows for text to appear in the lower right 

corner of the map. 

 Projection – Select or change a projection from the list. 

Note that for maps with basemaps it is not possible to a 
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change a projection. 

The projection can be defined by: 

 Searching for a projection by entering its EPSG number or 

 Searching for a projection by using keywords 

 Map units – Select from Meter, Degree, Foot or Foot_us. 

 Background color – Defines background of the Map View. 

 Max zoom – Optional setting for scale dependency which limits the scale at which the layer is visible 

 Bounds – Saves coordinates of your current view or manually imputed coordinates. Every time you 
refresh your map or click on View entire map you get the view extent of map you bounded to 

 Clear map tiles – if you experience any problems with the map display, you can clear layer tiles or 

reinitialize the map. 

Import and Export Data  

 

Upload Data  

You can upload various types of data including:  

 Spatial Vector files: .shp, .mif, .mid, .tab, .kml, .gpx 

 Spatial Raster files: .tif, .tiff, .jpg, .gif, .img, .ecw, .sid, .jp2 

 Image files: .jpg, .gif, .swf, .png, .img, .ecw, .sid, .jp2 

 Excel 2003 and CSV: .csv and .xls 

The four methods of uploading files into GIS cloud are:  

1. Drag & Drop  
You can drag and drop files in the Home Tab/Map Gallery or inside of a map. Either way data will be 

uploaded into your File System. Make sure that you drag and drop all files that are part of your 
data (for example, if you want to drop shapefiles then you have to drag and drop all the files that 
are part of a particular shapefile). 

2. Upload through file manager  

3. Upload through the SFTP client  

 

Import CSV or XLS 

 

If you have data geocoded with location coordinates you can upload it as an Excel table or CSV. 

This data can then be visualized as a layer. See the sample data table below. 
 

 

To perform data import, go to the Layer Tab and select the Import function. 
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Browse for the data table on your computer and 

upload it to GIS Cloud. Set the table parameters and 

select the coordinate fields. When everything is set 

browse the output file for which the dataset needs to 

be created in PostGIS database. The action is set by 

default for now. Now select Import and your data is 

ready to use. 

 

 

 

 

 

 

 

 

 

 

Adding Layers  

 

To add layers, first you have to open the Source Browser by selecting Add Layer option that can 

be found in the Map tab and in the Layer tab or by selecting Add Layer button in the Layer List. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Layers can be added from several sources: local computer/File System, Database, Web Map 

Service, Tile Map Service (Open Street Maps, Google maps etc.), GIS Cloud Maps, Mobile 

Devices and/or Arcmap extension. 

Select source and the desired layers you wish to add and press Select to add layers. 

http://www.giscloud.com/manual/map-editor-manual/getting-started/main-user-interface/layers-panel/
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Click Start Adding button to add layers into the map. Note: hold CTRL key on your keyboard 

for multiple selection.  

Creating and Editing Layers  

 

Creating Layer 

In addition to uploading data layers, you can also create new layers by:  

1. Select the Layer Tab 

2. Select Create Layer from the Add Layer dropdown menu  
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Choose or enter the data (attributes) that the layer will have: 

 
1. Table name - Enter the name of your new GIS data layer. 

 

2. Geometry type - Select point, line or polygon as your feature type. 

 
3. Projection - Select a new projection or select an existing one being used in the active map. 

 

4. Overwrite if exists - You have the option to overwrite an existing data layer if it bears the 

same name as your new data layer. 

 
5. Copy Structure Form - You may define the structure of your data layers’ table by copying 

the attribute table from another existing layer. This operation does not define point, line or 

polygon geometry. 

 
6. Attributes - Enter the desired field names for your new data layer and define the field type: 

 String - Input any text 

 Real - Input numbers containing a decimal point 

 Integer - Input whole numbers 

Editing Layer 

 

A layer can be edited through Layer Properties. You can access it by:  

 Double clicking on the layer in the Layer list  

 Select a layer and edit layer tool from the Layer tab 

 Select Edit Layer function from the dropdown menu 
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Geometry editing  

The layer can be modified by using edit tools.  

Features in the layer can be edited by 

the following step:  

1. Select a database layer from 

the Layer List. 

2. Select the Edit feature from 

the ribbon (on the Feature 

tab). 

3. Select the feature which 

geometry you wish to edit 

and move the vertices to the 

desired location. 

4. Choose Save to save a new 

point location or Cancel to 

undo editing. 

 

*Note: to perform higher accuracy select Snapping Option.  

It is also possible to edit feature geometry through the Info Panel.  

1. Select a feature. 

2. From the Info Panel 

choose Edit Geometry. 

3. Change a location of the 

feature. 

4. Click Save button. 

 

 

 

 
 

Adding Features 

To add new features, edit geometry or perform analysis, layer has to be imported into the database. Add 

new point features to the layer by following these steps:  

 

1. Select a database layer from the Layer List  

2. Select the Add feature from the ribbon (on the Feature tab)  

3. Select Snapping and/or Measuring option (optional)  

4. Click on the map to add new feature  

5. When done editing press Enter on your keyboard or:  

a. End line by clicking in the last added point  

b. End polygon by clicking on the first polygon point  

6. Enter attributes in the feature table form and choose Save.  

http://www.giscloud.com/manual/map-editor-manual/tools-tab/database-manager/
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A layer can be edited by following these steps: 

 
1. Select a point layer on the Layer Panel. 

2. Select the Edit feature from the ribbon (on the Edit Tab). 

3. Select the layer displayed on the map. 

4. Move point to the desired location. 

5. Choose Save. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Selecting Layers and Objects 

Any feature can be selected. Selected sets allow operations to be performed on your layer, 

geographic area or feature of choice. 

 

Select feature attributes  

There are a few ways to see features attribute data:  

 

Data Grid displays all features attributes of the selected layer.  

1. Select layer in the Layer List 

2. Hold and drag Grid button from the bottom of the map view to expand Data Grid  
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3. Browse through attribute data associated to each feature of selected layer 
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The selected feature is zoomed and 

highlighted when you click on the attribute 

associated with it. Identify tool enables you to 

see attribute data of the selected feature in the 

info panel. When the tool is used the Info 

Panel appears on the right side of the screen.  

 

 

 

 

 

 

 

 

Multi-select Method  

 

Multiple features may be selected at once. There are two methods for multiselection. The first 

method is the Select Tool. 

 

1. Click the select tool on the Map View toolbar. 

 

2. Hold the CTRL button to select multiple features in a layer 

 

 
 

The second method is the Area Selection tool. 

 
1. Select the layer in the layers’ panel on which you wish to do a multiselection. 

 

2. Click the Area Select tool on the Map View toolbar. 
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3. Drag a box to define the area of selected features. 

 

The selection of objects can be cleared with the Clear Selection function from the Feature tab. 

 

Invert Selection Tool 

 

This tool is use to select the unselected layer elements, and unselect the selected ones. The invert 

selection tool is found under the Feature tab.  

 

Before:  

 

 

 

 

 

After: 
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Creating a New Layer from Selection  

 

New layers may be created from selected sets.  

1. Select features by using:  

 Select tool from the Toolbar (Ctrl + Select) or  

 Area Selection tool from the Toolbar  

2. In the Feature tab choose New Layer from Selection  

 

 
 

The new layer result should look like this:  
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Spatial Selection  

 
Note: spatial selection only works with database layers, not with files. If you want perform spatial 

queries, please import the files into the database first (See database manager or exercise) Spatial 

selection allows you to create database queries for layers that reside in the database.  

 

This tool allows you to select any database feature from any database layer in your Map View. You 

can select by attributes or by location depending on what do you need. 

 

1. Click the Select tab 

 

2. Select Spatial Selection 

 

 
 

Example 1: Base the selection with polygons that have id attribute less than 1800  

 

Select column from the dropdown list.  
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Select column from the dropdown list  

 
Write condition “i.e. <1800” then Click Select  

 

 

Click New Layer from Selection then click clear selection  

 
 

Example 2: Select lines within the polygons:  

 

1. Click ST_within() or write it into the Condition bar  
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Select line layer and geometry column (wkb_geometry)  

 
 

2. Click “+” button to add another table  
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3. Select polygon layer and geometry column (wkb_geometry)  

 
4. Click Select button  

5. Click New Layer from Selection  

6. Click Clear selection  

 

GIS Analysis  

 

All spatial data included in a project can be analyzed using the following tools:  

1. Area analysis 

2. Buffer analysis  

3. Heatmap analysis  

4. Near analysis  

To access analysis tools go to the Analysis tab  

Note: you can perform Analysis only with layers added to the map from a database.  

 

Area analysis  

Area analysis calculates the surface 

area of a selected polygon.  

1. Select database polygon layer  

2. Select layer’s feature 

3. Click Analysis tab 

4. Click Area icon 

5. Select units of measurement 

from the drop down list  

6. Click calculate for selection 

button  
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Buffer Analysis  

 

Buffer analysis creates a zone around a point, line or polygon. You can identify whether there are 

objects of interest inside the zone or outside the zone and make conclusions based on this analysis. 

After selecting Buffer analysis from the analysis tab you need to set following options: 

 

1. Select Analysis tab  

2. Click Buffer icon  

3. Write Analysis name 

4. Select database layer from the dropdown to perform analysis on  

5. Define buffer distance and the unit of measure 

6. Choose whether you want to group (merge) buffers 

7. Define the symbology of the buffer polygon  

8. Click Show buffer button 

 
 

 

 

 

 

 

 

 

 

 

 

Heatmap Analysis  

  

Heatmap analysis is a graphical representation of data that visualizes the density of points in a layer. It is 

possible to perform Heatmap analysis on the point layers that reside in the File System or in the Database.  

 

To calculate density of points in a layer and display it on the map: 

1. Select Analysis tab 

2. Click heatmap icon  

3. Select database point layer 

4. Set minimum distance between points taken into consideration to calculate density  
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5. Select show hotspots to see the results  

 
 

 

 

 

 

 

 

 

 

 

Near Analysis  

 

Near analysis is a tool with which you can determine the distance from each feature in a layer to the 

nearest feature in the same layer, within the specified search radius. 

 

To perform a near analysis:  

1. Select Analysis tab  

2. Click near icon 

3. Select database point 

layer 

4. Set distance (search 

radius) and units of 

measure. Note: you 

can speed up the 

process time by 

setting bounds to 

local region  

5. Click run button  
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You can see the number of selected features in the Toolbar. You can also create a new layer from 

selection: Feature tab > New layer from Selection. 

 
 

Tools Tab  

The tools tab gives access to the following operations in the ribbon: 

1. Work with files 

2. Work with the database 

3. Join data from separate layers 

4. Create source from various types of data 

5. Create layers form 

6. Set spatial projection options 

7. Merge two shapefiles into one 

 

 

http://www.giscloud.com/manual/map-editor-manual/tools-tab/file-manager/
http://www.giscloud.com/manual/map-editor-manual/tools-tab/database-manager/
http://www.giscloud.com/manual/?p=3825
http://www.giscloud.com/manual/?p=3379
http://www.giscloud.com/manual/?p=3057
http://www.giscloud.com/manual/map-editor-manual/tools-tab/projection-wizard/
http://www.giscloud.com/manual/map-editor-manual/tools-tab/merge-wizard/
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File Manager  

This is used for managing and uploading new files to GIS Cloud.  

 

The file manager offers the following functionalities: 

1. Tools  

o Refresh Current Folder 

o Select All 

o Create new file – file name can’t contain ‘/’ or ‘\’ characters. 

o Edit text file 

o Create New folder 

o Duplicate file/folder 

o Move to different folder 

o Rename 

o Edit structure – at the moment only ESRI Shapefile is supported. 

o Unzip archive 

o Download selected file(s) 

o Delete 

2. Upload data from local computer 

3. Address bar 

4. Name of the currently selected file/folder 

5. Filter files by file type 

6. Search files by name 
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Database Manager  

To perform editing or data analysis, the layers you’re working with must reside in the database. 

The Database Manager allows you to import layers into the database. 

To import file into the database: 

1. Click Tools tab and click Database Manager icon. 

2. Click Import Geospatial file icon. 

 

3. Select layer you want to import (or upload it to the GIS Cloud).  

4. Click Select button.  

5. Write table name.  

Note: when naming table: start with a letter or an underscore, use only English alphabet 

letters, digits and underscores, and use only lower cases 
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Projection – Info about layer projection 

 

Reproject to – If box is checked, it’s possible to reproject layer from original projection to 

another projection 

 

Encoding – character encoding is used to represent a repertoire of characters. You can 

choose between encoding, but note that original layer has to have UTF-8 encoding 

 

Geometry type – spatial data can be represented as point, line, polygon, multipoint, 

multiline or multipolygon. If original layer is multipoint, multiline or multipolygon type,  

check “Expolode geometry box since multigeometry can’t be imported in the Database 

 

Overwrite existing – Overwrites existing table with the same name 

 

Explode collections – Explodes multigeometry features to the geometry (i.e. multipolygons 

to polygons) 

 

Skip failures – Skips features that can’t be imported to the database 

 

Use shp2pgsql – Converts a shapefile into a series of SQL commands 

6. After choosing layer and defining options click Import button. 

Note: make sure that layer has UTF-8 encoding. 
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Adding Database layer to map  

After importing, database layer has to be added to a map. Database is the required data source for 

editing geometry and performing any data editing, calculations, or analysis. 

Database layer is added to a map as shown below: 

1. Select Add Layer from the Layer tab or Map tab. 

2. Select Database from the dropdown menu. 

3. Select a table. 

4. Click Select button. 

 

Projection Wizard  

This tool enables you to change an existing layer projection. To access Projection Wizard, click 

on the Tools tab.  

1. Browse to a datasource layer. If the projection has been detected, it will appear in the 

form. 

2. Select new datasource projection (SRS – Spatial Reference System Identifiers) and click 

Select to add it. 
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3. Choose Assign an output SRS to correct the current projection. If you wish to transform 

datasource from an existing projection to the newly selected one, choose 

Reproject/Transform to SRS on output. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To help you find the projection you want, you have a search tool at your disposal. You can search by 

EPSG code or by all columns. For more informaiton on projections, visit http://www.spatialreference.org. 

 

Merge Wizard  

This enables you to merge several files into one. It is current supports forms in ESRI Shapefiles for 

vectors and GeoTiff files for rasters. If source files are stored in the File System then destination file has 

to be in the File Manager too. If all source files are stored in the Database, then destination file has to be 

in the Database too. If one of the source files is stored in the File Manager and other in the database, 

destination file has to be stored in the File Manager. Note that layers stored in the File Manager are not 

editable. Source layers have to have same geometry type (point, line or polygon). It is not possible to 

merge e.g point and polygon. It is also possible to merge data collected with MDC. MDC data is stored as 

a table in the Database. 

 

To merge:  

1. Select Merge Wizard from Tools tab  

2. Browse files you wish to merge from the File System or Database  

3. Browse Destination for a merged file. Follow the steps below depending if your layers are stored 

in File System or Database  

 

Geocoder  

With the Geocoder you can easily convert non-spatial location data into its matching spatial 

representation. Geocoding allows users to translate an address into coordinates and vice versa. 

 

For geocoding you will need an excel table or a csv table containing data you want to geocode and the 

address model data that will be the basis for geocoding. 

http://www.spatialreference.org/
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Sharing and Publishing  

 

GIS Cloud has several options for sharing and publishing data. To share or publish data, first select the 

Map tab and then click Share or Publish from the ribbon. These related sections follow: 

 
• Map Sharing with other GIS Cloud users 

• Setting Layer Permissions 

• Embedding Maps into a Web Page 

• Web Map Service (WMS)  

 

Map Sharing  

1. Open map you want to share  

2. Click the Share and Publish option on Map Tab 

 
3. Start to write GIS Cloud username of the user you want to share a map.  

 

 
4. Click Share and set Sharing Permissions for users  

 

List of Share or Publish form functions include:  

1. Permalink – The URL appearing in the permalink field allows you to share a direct link 

to your project from any browser.  

2. Open in Map Viewer – opens a map in the Map Viewer application.  

3. Share with the User – write username of the user you want to share a map with.  

4. Publicly available – if box is checked maps are visible to everyone on the Home tab 

under Public Maps, whether they are registered or non-registered GIS Cloud users.  

5. Who has access – Collaborate with other GIS Cloud users.  

http://www.giscloud.com/manual/map-editor-manual/sharing-and-publishing/map-sharing/
http://www.giscloud.com/manual/map-editor-manual/sharing-and-publishing/set-layer-permissions/
http://www.giscloud.com/apps/map-viewer/
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6. Permissions  
• Can view – will provide only viewing privileges to the person you have shared your 

map with. 

• Can share – will provide sharing privileges to the person you have shared your map 

with. 

• Can edit – will provide complete editing privileges to the person you have shared 

your map with. 

• Can export – will allow the person to export the map you have shared with him 

• Can collect – will allow the person in the field to send new data, without possibility to 

make changes to existing data or the one that he has already sent through Mobile Data 

Collection application. 

• Can update – will allow the person in the field to make attribute and geometry 

changes, without possibility to send new data through Mobile Data Collection 

application. 

 

Layer Permission  

Regardless of map privileges you have set for another user, there are additional sharing options 

you can set for each layer individually. 

http://www.giscloud.com/apps/mobile-data-collection/
http://www.giscloud.com/apps/mobile-data-collection/
http://www.giscloud.com/apps/mobile-data-collection/
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To share a layer follow these steps: 

1. Select layer on the Layer list. 

2. Choose Share Layer option. 

 

1. Write username of the user you want to share layer with. 

2. Set sharing permissions: 

 Can view – will allow the person you have shared your map with only viewing 

privileges of specified layer, without possibility to edit or export it. 

E.g. If you gave other user edit privileges to the map, but want to make restricted 

privileges for a specific layer. 

 Can share – will provide sharing privileges to the person you have shared your layer 

with. 

E.g. If you gave view privileges to the map, but want to enable other user to share a 

layer to another user. Person with share privileges can share layer to another user and 

assign him the same permissions he got from the layer owner. 

 Can edit – will provide the person you have shared your map with complete editing 

privileges of specified layer. 

E.g. If you gave other user view privileges to the map, but want him to be able to edit 

a specific layer. 

 Can export – will allow the person to export specific layers from the map you have 

shared with him. 

E.g. If you gave other user view privileges to the map, but want him to be able to 

export a specific layer. 

 Can collect – will allow the person in the field to send new data to a specific layer, 

but without possibility to make changes to existing data or the one that he already 

sent through Mobile Data Collection application. 

 Can update – will allow the person in the field to make attribute and geometry 

changes for features in a specific layer, but without the possibility to send new data 

through Mobile Data Collection application. 

 Publicly available – makes the layer publicly available for all GIS Cloud users. After 

making layer public, it’s also possible to choose between view, edit and/or export 

privileges. 

Note: Sharing Layer and Sharing Layer’s data source is not the same option. Shared Layer will 

allow other user to use layer only inside the map which you also need to share with them. Shared 

data source allows other users to use layer in any map, his own or the ones shared to him with 

edit privileges.  

 

http://www.giscloud.com/apps/mobile-data-collection/
http://www.giscloud.com/apps/mobile-data-collection/
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Embedding Maps into a Web Page  

Choosing the embed tab on the Share and 

Publish panel allows you to easily extract 

code for the embedding of your map in a 

3rd party website. The following settings 

are available: 

 
1. Define your preferred scripting 

platform: 

 GIS Cloud (Javascript) 

 Google Maps 

(Javascript) 

 

2. Width X Height - Define the 

dimensions of the object 

 

3. Choose your content display 

method 

 

4. Options - Opt to include a toolbar, 

a Layer List (Legend) and/or Info 

Popups 

 

5. Popup Preview – Examine a 

complete preview of your map 

prior to embedding 

 

6. Code - Copy code into the part of 

the page where you want to show 

the map 

 

There are some differences in the forms for each of the scripting platforms but in general the 

settings are the same. If you experience any problems or issues with the maps, use Clear Tile 

Maps and then try again. 

 

Web Map Service – WMS 

 

You can share your GIS Cloud map on a third party software as a Web Map Service (WMS). To share 

a map as a WMS:  

1. Click Share or Publish button from the Map tab. 

2. Click Enable button. 

3. Copy and paste WMS URL link to the third party software i.e. QGIS, Google Earth, 

ArcMap. 
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