You are here

Browser requirements

The OnBase web client is supported for use with the following:

  • Internet Explorer 11

  • Chrome 49+

  • Firefox ESR 45, Firefox 45+

  • Safari 6.2.x, 7.1.x, 8.0.x, 9.0.x, 9.1.x, 10.0.x

Other browsers or versions may or may not work, depending on which features of OnBase you are using.

OnBase version 16 requirements