Internet Explorer Critical security flaw

Wednesday, April 30, 2014

On April 26th, Microsoft announced a critical security flaw with the Internet Explorer (IE) browser.  The flaw was discovered as cybercriminals were using it to target organizations in the USA.  The flaw affects IE versions 6 through 11 on Microsoft Windows.  It is not known when Microsoft will provide a fix.  

Given the criticality, it is recommended that IE users move to an alternate browser (such as Chrome or Firefox) and also set this as their default browser (Start > Control panel > Default programs).

  1. 2019 (4)
    1. October (1)
    2. July (1)
    3. April (2)
  2. 2018 (2)
    1. October (1)
    2. May (1)
  3. 2017 (10)
  4. 2016 (13)
  5. 2015 (17)
  6. 2014 (16)
  7. 2013 (30)
  8. 2012 (8)